Run This Important Update: ParadEyes.com Security Certificate Expired on 8/5/19

The ParadEyes.com Security Certificate on your MaximEyes workstations will expire on 08/05/19.

To ensure that you don't experience an interruption in submitting your orders via ParadEyes.com, please log in to First Insight's For Customers website at https://customer.first-insight.com and run this update on each workstation where you submit orders via the ParadEyes.com integration.

How to Run the Update on Each Workstation:

  • Once you log in to the For Customers website, click the DOWNLOADS menu tab.
  • Click the MaximEyes-ParadEyes.com Integration Update (All MaximEyes Versions) released June 10, 2019.
  • A new message window will appear asking if you want to Run or Save the file. Click the Run button.
  • Your browser may display the following prompt:
    "MaximEyesParadEyesSecurityUpdate2019.exe is not commonly downloaded and could be dangerous." Select the option to "Keep" it and double click the .exe.
  • A second message will appear to verify if you want to run the update. Click the Run button again to install the MaximEyes-ParadEyes.com Integration Certificate Setup Wizard.
  • Click the Next button.
  • Click the Finish button.

Need help or have questions about the MaximEyes-ParadEyes.com security certificate update? Contact Technical Support at 800.920.1940, Option 3 or Email Technical Support.

MaximEyes Cloud Users Only: The security certificate update will automatically be done by First Insight so there is no need for you to download the update.